Knowl­edge Base

FAQ on myMap.

What are the system requirements for myMap?

Applies to: 2018, v.5

Article ID: KB200081
Last Modification: April 14, 2017

General recommendations:

myMap 2018 (PC)

MYmap 2018 (PC) is designed for use with Windows 10, 8 or 7. There are no special requirements.

myMap 2018 (Mac)

MYmap 2018 (Mac) is designed for use with macOS Sierra. There are no special requirements.

myMap v.5

MYmap v.5 is designed for use with Windows 10, 8 or 7. There are no special requirements. If you still use Windows Vista or XP, you may use myMap v.5 with it. However, we strongly recommend you update your machine.


Has this information been helpful?

Yes No


Site Notice and Privacy